Back to overview
Maintenance

System diagnostics

Sep 18 at 01:00pm CEST  –  Sep 18 at 09:48pm CEST
Affected services
Bancho
Website

Resolved
Sep 18 at 09:48pm CEST

we updated our whole server to keep up to date with all latest software features.

Created
Sep 18 at 01:00pm CEST

We try to find some issues that are recently occurring on the main server.