Get in touch
Back
Maintenance

System upgrade

Completed 19 May at 12:04am CEST.

API Avatar-Service Bancho Beatmap Mirror Score-Server Website
Completed

We successfully updated our System, all Services should work like they should

Posted 19 May at 12:04am CEST.
Started

We are updating the system, all services are unavailable for this time.

Posted 18 May at 11:30pm CEST.