Get in touch
Back
Maintenance

Score-Server Update

Completed 31 May at 08:28pm CEST.

API Avatar-Service Bancho Beatmap Mirror Score-Server Website
Completed

Our new score server is now online and hopefully working!
RIP LETS

Posted 31 May at 08:28pm CEST.
Started

RIP LETS, you served us well.
Also we will check if the MySQL Server is now stable again after lets has been taken off.

Posted 31 May at 07:30pm CEST.